Esc Cut Out

Discussion in 'YGE' started by D1NO, Mar 14, 2015.

By D1NO on Mar 14, 2015 at 10:34 AM
  1. D1NO

    D1NO Member

    Joined:
    Nov 25, 2014
    Messages:
    41
    Likes Received:
    22
    So I have 2 helis that are playing up.
    Both helis have the same problem.
    Not every flight but just random times.
    Occasionally during flight the throttle cuts out.
    One is a raptor e550 w TALON 90, AR7200bx + satellite on 6s
    The other is mini protos w YGE 60, mini vbar, AR610 on 3s
    Raptor has cut out during spool up and during flight ... Still have cyclic control .. Then motor spools up again after 2-3 secs
    Mini p has not cut out on spool up .. Usually does it after going to idle up 2 ... Even while hovering not under load. Throttle does not come back, just falls out of the sky.
    Both are not a soft cut off, motor just stops !
    Neither are coming down with errors on esc .. No beeping or flashing lights .. And receivers are solid
    Tried a different radio ... Same issue.
    Is this just a coincidence that I have two crapped out speedys at the same time or is there something else I could be missing ?


    Sent from my iPhone using Tapatalk
     

Comments

Discussion in 'YGE' started by D1NO, Mar 14, 2015.

    1. D1NO

      D1NO Member

      Joined:
      Nov 25, 2014
      Messages:
      41
      Likes Received:
      22
      Ps ... I have at least 4 other helis with no problem ... As yet !!


      Sent from my iPhone using Tapatalk
       
    2. Fredo

      Fredo Well-Known Member

      Joined:
      Mar 19, 2014
      Messages:
      190
      Likes Received:
      273
      Just curious . With the E550 is the throttle curve linier or have you set a flat line ?
       
    3. D1NO

      D1NO Member

      Joined:
      Nov 25, 2014
      Messages:
      41
      Likes Received:
      22
      Flat line curve .. Running castle governor


      Sent from my iPhone using Tapatalk
       
    4. Manyc

      Manyc Well-Known Member

      Joined:
      Mar 14, 2014
      Messages:
      1,619
      Likes Received:
      1,189
      I've had it in the mini protos.. Turned out I think to be my rx... The other thing that I have heard happen is the model gets screwy in the radio and to re create the model in the radio from scratch..
       
    5. D1NO

      D1NO Member

      Joined:
      Nov 25, 2014
      Messages:
      41
      Likes Received:
      22
      Re soldered the cap on YGE 60 .. Hopefully that sorts out the mini p ...
      Still not sure what to try on the raptor talon 90


      Sent from my iPhone using Tapatalk
       
    6. The Dude

      The Dude Well-Known Member

      Joined:
      Mar 4, 2014
      Messages:
      1,070
      Likes Received:
      650
      I would go over and re do all the connections for sure... Also look for any small nicks in wires touching metal or carbon. Also check all the servo plugs to make sure all the wires are fully seated into each servo plug.
       
    7. smakmeharder

      smakmeharder Administrator

      Joined:
      Mar 3, 2014
      Messages:
      4,803
      Likes Received:
      3,093

      OK what battery packs are you using? Also what battery connectors are you using?

      This scenario is usually due to insufficient power supplying the ESC. Also regarding the MINIP definitely check the two electrolyte caps, if one cap comes disconnected it will reset during flight randomly.

      Things to check:

      Make sure the leads coming from your battery connector to the esc are solid and have no frayed or internally broken strands of wire.

      Make sure the plugs connecting the battery to the ESC are solid and have NO loose fittings which may cause intermittant connections.

      If you are using EC2, consider switching to EC5. I used to have drop outs all the time using Ec2. Since moving to EC5, never an issue. Less dropouts is due to the greater contact surface area...

      Carefully check that the terminal connectors inside the rc Plugs, expecially the one coming from the ESC . Sometimes they "PUSH BACK" into the casing creating an intermittent connection.

      [​IMG]


      As dude said, check for ANY wires shorting to the frame as well.

      Hope this helps...
       
      • Like Like x 1
      • Informative Informative x 1
      • List
    8. D1NO

      D1NO Member

      Joined:
      Nov 25, 2014
      Messages:
      41
      Likes Received:
      22

      Using gens ace in both helis ...


      Sent from my iPhone using Tapatalk
       
    9. The Dude

      The Dude Well-Known Member

      Joined:
      Mar 4, 2014
      Messages:
      1,070
      Likes Received:
      650
      Also make sure there is no CARBON build up in the plug's, have had issues with that in the past on EC5's , remember @smakmeharder
       
    10. feral

      feral Well-Known Member

      Joined:
      Mar 14, 2014
      Messages:
      2,299
      Likes Received:
      1,461
      Agree 1000%

      My 500 cut one day turned out the esc leads where broken 10mm from the plug
       
    11. smakmeharder

      smakmeharder Administrator

      Joined:
      Mar 3, 2014
      Messages:
      4,803
      Likes Received:
      3,093
      Found the resolution to this problem @D1NO? I would love to know the conclusion.
       
    12. D1NO

      D1NO Member

      Joined:
      Nov 25, 2014
      Messages:
      41
      Likes Received:
      22
      So I pulled the YGE out of the mini. P .. And replaced it with a castle ice lite 50 .. This stopped the cut outs, but caused "cogging" / stuttering on spool up .. Once up to speed it flew fine.
      Triple checked settings in castle gov .. Tried a couple different pwm ... Same prob !
      Argy Pak suggested it could be a damaged motor .... I've got no idea .. Gave up and put castle back on the x3
      Haven't even looked at raptor yet !!!


      Sent from my iPhone using Tapatalk
       
    13. D1NO

      D1NO Member

      Joined:
      Nov 25, 2014
      Messages:
      41
      Likes Received:
      22
      Oh yeah .. Went and bought a new transmitter because I was scared it was a radio problem ... It wasn't :(


      Sent from my iPhone using Tapatalk
       

Share This Page

test

    About Us

    Just like you, Heligods staff are regular everyday fliers. Join our forum and participate in what will become the worlds greatest rc helicopter forum..

    Credits:

    A big thank you to the following people who helped us put together this site:

    Pope Francis

    Deli Lama

    George Bush

    Gene Simmons (aka Crash)